Jump to content

How to properly report an issue on the statspage.

Recommended Posts

Hey community, 

if you have an issue with our stats page, please follow this guide how to properly report an issue.
I need to clarify the situation in any possible way, and just to mention "something is not working" is not an indicator I can work with.

The following information is required:

  • What version is the stats page on, you can find that info on the top right of the page:
    image.thumb.png.6cecc345be7c55beaa054bd56f819eb5.png
  • What is the EXACT issue?
  • Did you do anything prior since when the issue does appear, like connect an account / switch main account, search a player?
  • Open the console "F12" and make a screenshot of that as well, something like this:
    image.png.e0760ccf975aab18c50ee7d03f3b6d4a.png
    Please include any errors you see on that console, it mostly will cause the issue you got there.
    Prior the screenshot, please clear it, refresh it and then take it. Complete logs of the live stats are not helping me to identify the issue.
  • What are OS / Browser version you using? (Version is visible in "about" section of your browser)

That is it. If I cannot indicate a named issue in the chat I will ignore it as I cannot reproduce it. Just create a topic with the mentioned details and I can take a look at it.

I have gotten multiple requests recently which I simply cannot reproduce or further check as the details are missing. Keep in mind you also won't go to the bank and state that for an example a transfer was wrong, without specify which transaction, when, to whom and from.

Please create any topic related to the stats page with the guide above in the feedback/complaint section.

Thanks,
Grief
 

Share this post


Link to post
Share on other sites

My issue was that the running games page did not refresh itself and i manually had to press f5 everytime i wanted an updated version of the site (to see who really is currently ingame)

 

Right now it seems to be working just fine but in the console i do get some errors:

Tried 2 tabs simultaneously

First tab:

Capture.PNG.b3c72dd615e13e195df558ff11d9e7ea.PNG

Capture4.PNG.1cb93f67611c2ed10010ea45a3d5a100.PNG

Capture5.PNG.9f7bae359d115ea74752beff3cdd9774.PNG

 

Second tab:

Capture2.PNG.40944c7ce9325189f346c7d3202aa623.PNG

Capture3.PNG.20f57ab60e0936d61de82961130e72c0.PNG

 

Again the page IS working fine for me since you created this topic.

 

Chrome version is  63.0.3239.84 (Official Build) (64-bit) 

Going to update my browser now and will post again if i can recreate the errors.

Statspage version is 1.6.27

  • Like 1

Share this post


Link to post
Share on other sites
6 minutes ago, FatmanKROUM said:

My issue was that the running games page did not refresh itself and i manually had to press f5 everytime i wanted an updated version of the site (to see who really is currently ingame)

 

Right now it seems to be working just fine but in the console i do get some errors:

Tried 2 tabs simultaneously

First tab:

Capture.PNG.b3c72dd615e13e195df558ff11d9e7ea.PNG

Capture4.PNG.1cb93f67611c2ed10010ea45a3d5a100.PNG

Capture5.PNG.9f7bae359d115ea74752beff3cdd9774.PNG

 

Second tab:

Capture2.PNG.40944c7ce9325189f346c7d3202aa623.PNG

Capture3.PNG.20f57ab60e0936d61de82961130e72c0.PNG

 

Again the page IS working fine for me since you created this topic.

 

Chrome version is  63.0.3239.84 (Official Build) (64-bit) 

Going to update my browser now and will post again if i can recreate the errors.

Statspage version is 1.6.27

Will fix the wrong domain for game sounds, I thought I replaced them a while ago, currently, I'm stuck however in the new dota score command.
Should be fixed tomorrow morning then.

Share this post


Link to post
Share on other sites
2 hours ago, FatmanKROUM said:

not getting any more errors since i updated to latest chrome version.

Suspected that issue.

Nevertheless, created a better guide:
https://wiki.ohsystem.net/display/DVSTAT/How+to+report+an+issue+on+ohstats.net
 

With German translation. However, I will also add detections of user agents, which then can identify directly such issues.

  • Like 1

Share this post


Link to post
Share on other sites
On 29.12.2017 at 11:00 AM, FatmanKROUM said:

managed to get a new error

Capture.PNG.09d728c57fca3147dfd5890c73b4a457.PNG

This issue is caused by some random occurrences when toaster messages disappear, this should not break the page.
There is a GitHub issue regarding that:
https://github.com/Dogfalo/materialize/issues/1031

Nevertheless, I will try to investigate the issue further when I have time, but as this is not breaking, it is not urgent for me currently.

Greetings

On 29.12.2017 at 12:33 PM, Drakonia[DRK] said:

I have the same problem too?

no.

1 hour ago, Drakonia[DRK] said:

@GriefCode can help me now with this problem, please?

Try to update your browser:

On 29.12.2017 at 10:02 AM, Drakonia[DRK] said:

I hope this helps.

Chrome.JPG

 

You have on the very right the "restart" option.
Use it, maybe it does resolve your issue then. I don't know actually. As your page does appear to work fine.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Who's Online   0 Members, 0 Anonymous, 0 Guests (See full list)

    There are no registered users currently online

  • Forum Statistics

    1007
    Total Topics
    6747
    Total Posts
  • Member Statistics

    1107
    Total Members
    138
    Most Online
    Newest Member
    bap
    Joined
  • Members

    No members to show

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.